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[bookmark: _Toc400034213]Introduction
This document describes installing the Vivado board definition files for the 7A50T Evaluation board so that the board appears in the menu list of available target boards when creating a new Vivado project.

[bookmark: _Toc400034214]Objectives 
This tutorial will demonstrate the following with the supplied files.
· Installation of the board definition files into the proper Vivado folder in your installation of the Vivado tools.
· Use of the board definition files ot create a new Vivado project targeting the 7A50T Evaluation board.

[bookmark: _Toc400034215]Installation Requirements
[bookmark: _Toc60371264]The following items are required for proper completion of this install guide.

[bookmark: _Toc297882830][bookmark: _Toc399925067][bookmark: _Toc400034216]Software
The software requirements for this reference design are:
· Linux, Windows XP, Windows 7, Windows 8.1 
(ug973-vivado-release-notes-install-license.pdf)
· Xilinx Vivado Design Edition software
· Version 2015.1 is used for this design

[bookmark: _Toc297882831][bookmark: _Toc399925068][bookmark: _Toc400034217]Hardware
The hardware setup used by this reference design includes:
· Computer with 1 GB RAM and 1 GB virtual memory (recommended)
(www.xilinx.com/design-tools/vivado/memory.htm)
· Avnet Artix-7 50T Evaluation board Kit
· Avnet Artix-7 35T Evaluation board
· USB-A to USB-micro B cables (UART and JTAG)


[bookmark: _Toc400034218]Supplied Files
The following directory structure is included with this reference design:

board_xml:  Contains the folder of board definition files to be copied to the Vivado install folders.

doc:  Contains documentation for this design:
7A50T_Board_Definition_Files_Install_Notes_VIV2015_1_v1_0.doc:  This document.

xdc:  Contains the master constraints file for the Rev. A  7A50T Evaluation board.
	7A50T_Master_XDC_PCB_Rev_A_v1_0.xdc

[bookmark: _Toc264821465]

[bookmark: _Setting_Up_the][bookmark: _Toc399925106][bookmark: _Toc400034219]Installation of Board XML Files
Many Digilent evaluation boards can now be targeted directly in the Xilinx Vivado tools.  This greatly simplifies the task of building the MicroBlaze processor system and integrating system peripherals and board interfaces into your own custom designs.  Follow the instructions below to install the board XML files for the 7A35T board into your Vivado 2015.1 installation folders:

1. Using Windows Explorer, copy the Avnet_7A35T folder from the deliverables folder(EX: C:\Artix-7\7A35T_Board_Definition_Files\board_xml) folder to <Vivado_install>\Xilinx\Vivado\2015.1\data\boards\board_parts\artix7:

      [image: ]
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[bookmark: _Toc399925107]

[bookmark: _Toc400034221]MB design on Artix-7 devices using vivado 2015.1
Before going to start creating project on Artix-7 35T device need to add board definition files in the vivado installation path.
(E.g.: vivado installation directory/vivado/2015.1/data/boards/board_parts/artix7/). For board definition files: https://reference.digilentinc.com/arty
To create a Microblaze based design, please follow the steps below to generate the design using the Artix-7 35T in vivado 2015.1 tool.
1. Open vivado and select Create New Project
[image: ]
2. Click Next at the first window and at the next window navigate to a folder of your choice to store the vivado project. Click Next to continue.
[image: ]
3. Click Next to create an RTL project (without sources).
4. Click Next at the following four windows to skip the addition of HDL sources, existing IP, and constraints.
5. Rather than just specifying a target FPGA device we will select the Arty as the target.  Click on Boards, then in the Filter section select digilentinc.com in the drop list.  This will display the list of Avnet boards that have board definition files installed in the Vivado tools.  Select the Arty 35T Board and click Next and then click Finish at the New Project Summary window.
[image: ]
6. The Project Summary pane should resemble the screenshot below:
[image: ]
7. Go to the Flow Navigator pane in and under IP Integrator select Create Block Diagram.
[image: ]
8. Choose a name for the block diagram design (or accept the default) then click OK to continue.
[image: ]
9. Navigate to the Board tab and double-click on the ddr3_sdram memory interface.
[image: ]
10. Click OK to continue. The DDR3 interface will be added to the block diagram.
[image: ]
11. Right-click anywhere in the white space of the design_1 block diagram pane and select Add IP.
[image: ]
12. Search for and double click on Microblaze.
[image: ]
And similarly you can add AXI UARTlite and AXI Ethernet lite and AXI GPIO using Add IP
After adding Ip’s the design_1 diagram lokks below:
[image: ]
13. Once Adding Ip’s completed click on Run Block Automation as shown in figure, configure like below secrren shot and click ok.
[image: ]
14. And next click on Run Connection Automation and remove the mig sys_click_i & clk_ref_i connections and add Clocking wizard and click on the Run Connection automation and configure clocking wizard by double clicking IP with three output clocks: 25MHz for Ethernet ref. clock and 166.666 MHz and 200MHz clock output to Mig sys_clk_i and clk_ref_i.
15. And connect interrupts of AXi timer, UARTlite and Ethernet lite to AXI interrupt controller using Contact IP. The final Block Design as shown in figure:
[image: ]
16. In Program and Debug pane Click on Generate Bitstream 
17. After the completion of Bitstream generation need to export hardware to SDK.
18. In the vivado tool, select File-> Export->Export Hardware design to SDK
Ensure that Export Hardware, include bitstream option are checked and click OK
[image: ]
19. To launch SDK tool, in vivado tool, select File-> Launch SDK and in launch SDK workspace location by default current project location click ok, it will launch SDK tool, as shown below:
[image: ]
20. After the SDK tool is launched, Create a new application project.Select File > New > Application Project. The New Project wizard opens
21. In the project wizard give project name as Echo_server and OS platform Standalone, Processor is microblaze and click next.
22. In the Templates window select lwip Echo Server and click Finish. The Echo server application is built as shown in figure.
[image: ]

Run the Software using SDK:  connect respective cables to host PC and target.
23.  Assign a static IP address to the Ethernet interface on the host PC/Laptop. 
a.Click Start > Control Panel > Network Connections > Local Area Connection.
b. In the General tab, select Internet Protocol (TCP/IP) and click Properties.
c. Select Use the following IP address.
d. Enter this address in IP address area: 192.168.1.xx (Ex: 192.168.1.100) 
e. Enter this address in Subnet mask area: 255.255.255.0.
f. Click OK.
24. To download the bitstream on the board, in SDK window select Xilinx Tools -> Program FPGA to display the Program FPGA GUI dialog box.
25. Ensure that both the MB_System_wrapper.bit file and the MB_System_wrapper.mmi file locations are proper, and then click Program.[image: ]
Figure: Downloading Bitstream File

26. Open serial terminal application (Tera Term) to see application prints and set Baud rate to 9600 0r 115200.
27. To run the application, use these steps:
		1. Create a run configuration specifying the ELF that needs to be run:
		     a. Select the application that needs to be run.
		     b. To create a Run configuration, select Run > Run Configuration.
	     c. Create a new run configuration by right clicking the Xilinx C/C++ application 
		(System Debugger) tab on the left pane.
[image: ]
Figure: Run configuration window
28. Click on Run to execute the demo.
29. After seeing prints on tera term(serial console) open cmd terminal in windows  you can do the following operation from host PC.
$ping 192.168.1.10 (From Host PC to board)
$telnet 192.168.1.10 7 (From host PC to board/target using telnet)
image2.png
@) =[10 « iy Bt Dsftion Fes » o 5ot > b i > < [o9 ) [ Sewoh boarfis

Organize v

pen  Includeinlibrary v Sharewith v Bum  Newfolder

U AT = ame Demodicd | Type Sze
)} Avty_Bourd Deintion_Fies
U e versons o vivado
)l Vivado 2015 or later @
B boardfies
0w
B mens
U reacy_for_downlond
Uisw
)l Workspace -
l arty  Dte modiicd: §/4/20151049 AM

Dy B/4/2015 10:49 AM  File folder

File folder





image3.png
0 << Xl » Vivedo » 20151 » data » boards » bowrd_parts » ari >

<[4y |[ Search anti7 »
e s e - A e
H Favorites 4 Name . Date modified Type Size

B Deskeop 0 scrt 1072005 TT2LAM  File older

% Downloads By S/IS/ISHSPM  File older

B Recent Places e T/ 419PM File older

0 anyr_ase SIS TTPM  File older

Librares Ui Aumet 18507 S/IS/ISHSPM  File older

Documents B et 180T Y2/ SAPM WinRARZIP archive e

& Music

& Pictures

H Videos -

I & items




image4.png
L Vivado 20151 =1

Fle Fow Tods Window telp Q- Search commands

VIVADOY " sens e XILINX

AL PROGRAMMABLE..

Quick Start | Recent Projects

project_1

2 ColnrticastH
project_t
Cifrtic7_3STIHW

OpenProject Open Example Project project_t

Cifrts-7_SOT_LOCKSTERjHW
arty_testz015.1

jLasks] Cildntc? 15T Profproject
- rty_test
& = Cifantc?_15TIHW
\ project_t
Cipitix7_jrw
Manage 1P pen Hardnere Manager i el Store:
project_t
M jproject_t
Information Center project_t

CilReview_ZETHiproject_I

project_1
z ot Trevor locksteP _artix/HW

2 B

Documentation and Tutorisls  Quic Take Videos Release Notes Guide g

Tel Console —oex
stare_gui .

&« v

caml Tvpe o TcL comnand here

New Project Wizard wil quide you thouugh the process of selecting design sources and a target device for a new project,





image5.png
Project Name
Enter a name for your project and specffy a drectory where the project data s il be stored.

Project name: | project_t

Project ocation: | Ci/Artixast

Create project subdrectory.

Project wil be created ats Ci/Artiastjproject_t





image6.png
L New Project =
Default Part

Choose a default Klinx part or board for your project. This can be changed late,

Soct ®pors [ Brd]

4 Fiter
Vendor diglentinc com s

Display tame: | Al Remaining

BoardRey: | Latest s

Reset Al Fiters
Search: | O
Display Name

Vendar BoardRev  Part

avalable
1O Pin Court il Version 10

EZI T
fr EY

=
<w | s | e | [ ol ]





image7.png
& B4

(Eoricsnray ) o x
Project Settings et 2 |5
Projectname:  project_t

Project location:  C:/ArtixaStproject_t
Product famiy: vt
Project part artyt (xcTasStisna24-1)

Top modue name: o defined

Board Part
Display name: Arty1

Board part name:_dliglentine.com:arty1:part0: .1

Repository path: ~C:/xinx|Vivadoj2015.1/datafboardsfboard_parts
URL: o diglentine comjivty.

Board overview:  Artyl

Synthesis

Status: Mot started
Messages: No errors or warrings
part xe7a3Sticsgae-1L
Strateqy:  Yivado Syrthesis Defauls

DRC Violations

»

»

Implementation
Status:

Messages:

part

Strateay:
Incremental compie:

Timing

ot started
o errors or warrings
xe7a3Sticsgae-1L

Vivad Iplementation Defauts
Hoe.

»

»

»





image8.png
4 Project Manager \

S Projec setings
&% add Sources

D Language Templates
£ 1 cataon

o D
CF oo
3 oo

Generate Black Design




image9.png
Please specify name of bock design

Design name;
Drrectory:

Specify source set:

desin_i]

5 <Localto Project>

5 Design Sources





image10.png
Board
AT Ee >
@ Arty1
@ clock (0 out of 1 connected)
LG s dock
- ethernet (0 out of 2 connected)
2550 eth.mdio_mdc
et i
E-@ gpio (0 out of 5 connected)
5 i _swiches_fbrs
RSy
D ld_tbts
5 push_buttons_tbks
1 e

55 memories (0 ot o 3 connested)

0 aspi_flash
0 spi
£ miscellaneous (0 out of 2 conected)
O
0 usb_uert

o

&b Sources | i Design

Sonals,_ B Board |





image11.png
J-. Connect Bosrd Component

Select an 1P blockinterface for connecting bosrd component ‘ddr3_sdrar

>

X Name e

T Create newp

&1 548 Memory Interface Generator (V16 7 Series) i, comipimia_7series:23
e i





image12.png
= Diagram X

[

31 4 desion 1

¢ @ Desiner Assistance avaiable. Run Comection Automation

&
Y
K
]
()
aQ mig_7series_0
s clkref_i[2y— '_I—D
=
=
=
&
"
5 —aresetn _init_callb_complete
[~ Memory Interface Generator (MIG 7 Series)
®
@
¢
«

Propertiss
Delete
copy
paste
Search,
Select All

Run Connection Automatian.
1P Settings.
Valdate Design

Create Herarchy
Create Conment
Create port

Create Interface Port
Regenerate Layout

Save as POF Fie,

Ctl+E
Delete
culvc
culev
Ctl+F
Ctrl+h

[

Ctl+k
CtrleL





image13.png
Search: | Q- microblaze (3matches)

Name. ww
iinx.comip:microbla:
& McroBlaze Debug Modue (MDM) ‘. com:pimdm:3. 1

£ MicroBlaze MCS i com:ip:microblaze_mc...

Select and press ENTER or drag and drop, ESC to cancel





image14.png
& Address Edtor X
51 s s
g\ @ Designer Assistance avalale, Run Block utomation. Fun Connection Automation

microblaze_0 ax_ethernetite 0

e
ok ref i

sy D

dor3_scram

A EtheretLite
ax_timer 0

Wicroblaze

mig_7series 0

Memory Interface Generator (MIG 7 Series)

‘S
K
o
[
a
&
®x
E ]
[~
)
@
<)





image15.png
4 Run Black Autornation =
Pt ke oy sy e o B o Sk an ol s s g Y.y

@ |27 Al Automation (1 ou of 1 seected)
V¥

Description

MicraBlaze connetion autamation generates local memory of selected size, and caches can be corfigured,
Microslaze Debug Module, Peripheral AXI interconnect, Interrupt Controler, 3 clock source, Processor
System Reset are akso added and connected as needsd.

& B4

Instance: ficroblaze_0
Options
Local Memry: E
Local Memory ECC;[None ~
Cache Configuration: [8K6
Debug Modue: Debugorly
Peripheral AXI Port: | Enabled +
Interrupt Controler: [V

Clack Connection: | fmig_7series_Ojui_ck s

Cancel





image16.png
% project L - [C/Av3St/project_project_ Lxpr] - Vivado 2015.1 =
He gt Fow ook Wndow Loyost Uow Hob Q Souchconnnds
FreooRhX @D UG K E G [Eouo JE e ® Ready

T oerd o x & adress Edtor_x
= @ Ee * * 3] dsdesign 1 »

4 Project Manager

CEh gl —
@ Project sttings B3 dock (1 outof 1 comectedy ] | X
8 s e &
(=45 ethernet (2 out of 2 connect] \
Q Longuage Tempistes 59 eth.mdio_mdc e
P Catdl et i ]
& ° o (oot s cnmaaay || | ¥
T T— oop e || |2
Integrator 0 i2e_pullups. fb ey S8t O Tkt Cortnes
2 Crate Bock esgn D ld_tbts & -
o — 5 push_buttons_tbks
o = preeryr
) Generae HockDesin & memorio (1 outof 3commec_| [
B el ccloam é = "ol
Kl i B =
4+ smuston 2
s FEAETRECN A |
@ ronsimtion Semep. 02 x| o | s
& _'E [ = Moy Inistocs Go e (MG e et
+ AL At = e 0.ch ot s r
@ Elboration ettings 8 = e S
5% Open Hlaborated Desian Name: K _wiz_0_ck_out1 e T e e
Parent naes desin_t - r—

+ Symthesis
5 Syrehess ettings
> Run syrthess

> B Open Syrthesieed Design e

General | Propertis | Pins |

Driver = ck_we_0jck o

4 Implementation

@ inplementaton settngs Tdconso
> Run Inplementation 2 | set_property location (2155 516} [get_bd ports Eth_ref_clk] 7
» B oren e oesn S| cetproperty losation (212 £72) (et b ports E ree e1x]
et broperty location (2155 602) [yer b ports Eeh_ref clk]
.+ roam st U1 | 2o properey Location (2105 752) [gec bd ports Eh ret clk] 8
@ Bitstrean Settings K s
B g I ] D

¥ Generste Sesream

[ T —— | T o T comna here

/5 Tel Console | © Messages | [ Log | 2 Reports | 3 Design Runs |





image17.png
Export hardware platform for software development.

Export to: | 69 <Local to Project>





image18.png
B C/C++ - system_bw_platform_0/systerm hlf -Xilinx SDK

File Edit Source Refactor Navigate

Search Project XlinxTaols Run  Window  Help

o TA-enNED 6@

$-0-a-N

-2

Quick Access [

[25 Project Explarer 52

BE%|Y
4 8B syster_uw_platform_)
Me_Design bt
Me_Design wrapperbit
Me_Design wrsppermi
[ systermet

P

= 0 || systemhdf 52

system_hw_platform_0 Hardware Platform Specification

De

jn Inform.

Target FPGA Device: Ta3sti
Created With: Vivado 2015.1
Created On: Fri Aug 07 12:43:46 2015

Address Map for processor

icroblaze 0

axi_ethernetiits 0
i_gpio 0
axi_gpio_1
axtimer
_timer_1

i_uartite

microblaze s intc
micrablaze__local_memory_dimb_bram_if_cntlr
icrablaze__local_merory_ilmb_brarm_if_cntlr
ig_Tseries 0

ig_Tseries

TP blocks present

Overiew!

48 Torget Connections 21| = 0 |2 Probi. | 2 Tesks| B Cons... 22| 1 Prop

£
-4 Local [default]
» (= Auto Discovered

No consoles ta display at this time,

0x4020£££E
0x4000££££
0x4001£££5
Ox41c0£££E
Oxdlc1fEEs
0x4060£££5
024120855
020000££££
020000££££
0x8EEEEEEE
0x8EEEEEEE

5 ||[E] shKLog 52
e

16:13:44 INFO

= B ||[Eou. % | @Mk, = O

An autline i not available.

BB=0

: Launching XSOB server: xsdb.bat - +

XSDE server has started successfu

: Project ‘system_hu_platform 0 cr





image19.png
B8 /o + - echo_server bsp/system.mss - Xilinx SDK
File Edit Source Refactor Navigate Search Project XiinxTools Run Window Help

[E=SECR =)

R AR CREED @ (G BrO QN @ BT
Quick Aecess [
[25 Project Explarer 52 = 0| systemhdf systernmss 53 = 0 Eout. 2| @M. = O
BE%|Y ¥ E

echo_server_bsp Board Support Package

£ echo_server
BB echo_server bsp

Wiacify this 659 s Setings] | Re-generate BSP Saurces
@ system_w_platform_0 93] [Re-g

Target Inform:

“This Baard Support Package is compiled ta run on the following target.

Hardware Specification: C:AArti35tiproject 1\SDK\system_hw_platform_Dhsyster.hdf
Target Processor: micrablaze_

Operating System
Board Suppart Package OS.
Name: standalone
Version: 5.0
Description: Standalane is 3 simple, low-level saftware layer. It provides access to basic
processar features such as caches, interrupts and exceptions as well s the basic

Features of a hosted enviranment, such as standard input and autput, profiing,
abort and exit

Documentation: standalone 5 0
Overview| Source

48 Torget Connections 52| = 01 |[EL Prob.. | & Tasks| B Cons.. 53 | I Prop..| @ Ter.. | = O |[E] SDKLog %
&£ Rty BBt BE-ri-

4 Local [default] CDT Build Console [echo_server]
& Auto Discovered text  data bss dec hex filename -

193377 1724 750747 45845 esebs echo_server.:
*Finished building: echo_server.elf.size’

16:26:09 Build Finished (took 6s.21lms)

An autline i not available.

BB=0

+ Launching XSDB server: xsdb.bat - +

XSDE server has started successfu

: Project ‘system_hu_platform 0 cr





image20.png
B Program FPGA
Program FPGA

Specify the bitstrear and the ELF files that reside in BRAM mernory

Hardware Configuration

e [ 9
e ) ()
B o Dot [sdece)

Bitstrearn; MB_Design_wrapper.bit T [
BMM/MMIFiles  MB_Design wrapper.mmi T [

Software Canfiguration
Pracessor

MB_Design_i/microblaze 0

ELE/MEM File to Initialze in Block RaM
bootlaop

Program Cancel





image21.png
Create, manage, and run configurations

Run or Debug 3 pragram using Syster Debugger.

CERX[B3- Name: echo_server Debug

type filter text m Application | (9= Arguments | I Environment| 5o Symbol Files | 1 Source | & Path Map | = Common
EH Performance Analysis

B Torget Communicaton Framework Debug Types [Standalons Applicsion Debug_~

Xl C/C ++ application (GDE) a
Xilime C/C++ spplication (System Debugg ||| <°M"*°te™ (Lo z

4 &, ilinx C/C++ application (Syster Debugg

ot [

Bitstrearn file MB_Design wrapper.bit Search.. [Browse,

s | ==

PaADmice [ beact ) (ec)

s e [Buto Detet ) [ect ]

Summary of aperations ta be performed

Resstentire systemn Following aperatians will be performed before aunching the debugger.
Program FPGA L The following processors will e resetand suspende.
P 2 microblaze_0
Frm 2. Bl processors nthe system will e suspended, and Applications willbe downioadec o th fllowing processors a5
specied n the Applications tab.
[IRun psT_post.config e i he o

[ Ensble Cross-Triggering

 ——

Filter matched § of 13 terns

®





image1.jpeg
ARTIX?




